Пожалуйста, укажите причину жалобы на комментарий пользователя и ваши контактные данные, по которым мы могли бы связаться с Вами для уточнения информации или уведомления о предпринятых действиях со стороны администрации сайта!
Отмена Отправить
X

E-mail:

Пароль:

| Забыли пароль?


Canon MF4018 в Ubuntu 10.10

Canon MF4018 в Ubuntu 10.10

В этой статье я хочу рассказать как легко и просто заставить работать Canon MF4018 в Ubuntu. Ведь на официальном сайте Canon драйвера для нашего принтера есть, однако для Ubuntu 10.10 они до сих пор не обновлены и посему не устанавливаются, ссылаясь на неразрешимые зависимости.

Нам понадобятся модифицированные драйвера:

  1. cupsys_1.3.8-1+lenny8_all.deb
  2. cndrvcups-common_2.10-1_i386.deb
  3. cndrvcups-ufr2-uk_2.10-1_i386.deb

Устанавливать пакеты надо именно в указанной последовательности, после чего перезагружаем компьютер, подсоединяем принтер (или перезагружаем его, если уже подсоединен) и ГОТОВО! Кроме того, эти драйвера Canon для Ubuntu 10.10 подходят для следующих моделей:

  • Canon BJC-4100;
  • Canon imagePRESS C1, C1+;
  • Canon imageRUNNER 2318, 2320, C1021i, C1021iF, C1028i, C1028iF;
  • Canon imageRUNNER ADVANCE 6055, 6055i, 6065, 6065i, 6075, 6075i, 8085, 8095, 8105, C2020i, C2020L, C2030i, C2030L, C5030, C5030i, C5035, C5035i, C5045, C5045i, C5051, C5051i, C7055i, C7065i, C9060 PRO, C9070 PRO;
  • Canon iR1018, iR1020, iR1022A, iR1022F, iR1022i, iR1022iF, iR1024A, iR1024F, iR1024i, iR1024iF, iR105Plus, iR2016, iR2016i, iR2018, iR2018i, iR2020, iR2020i, iR2022, iR2022i, iR2025, iR2025i, iR2030, iR2030i, iR2230, iR2270, iR2870, iR2870e, iR2870Ne, iR3025, iR3035, iR3045, iR3180C/Ci, iR3225, iR3235, iR3245, iR3530, iR3570, iR4570, iR4570e, iR4570Ne, iR5055, iR5065, iR5075, iR5570, iR5870C/Ci, iR5880C/Ci, iR6570, iR6570e, iR6570Ne, iR6870C/Ci, iR6880C/Ci, iR7086, iR7095, iR7105, iR8070, iR85Plus, iR9070, iRC1021i, iRC2380i, iRC2880, iRC3080/i, iRC3380, iRC3580/i, iR C4080i, iR C4580i, iR C5185i, iRC5185i;
  • Canon i-SENSYS FAX-L160, FAX-L3000, FAX-L3000IP, LBP-3370, LBP5970, LBP5975, LBP6650dn, LBP6750dn, LBP7750Cdn, MF4010, MF4120, MF4140, MF4150, MF4270, MF4320d, MF4330d, MF4340d, MF4350d, MF4370dn, MF4380dn, MF4410, MF4430, MF4450, MF4550d, MF4570dn, MF4580dn, MF4660, MF4690PL, MF5840dn, MF5880dn, MF6680dn, MF8030Cn, MF8050Cn, MF8330Cdn, MF8350Cdn, MF8450, MF9130, MF9170, MF9220Cdn, MF9280Cdn;
  • Canon LaserBase MF6530, MF6540PL, MF6550, MF6560PL, MF6580PL;
  • Canon LASER SHOT LBP3360, LBP3460, LBP5960;
  • Canon LBP5360;
  • Canon MF7170i;
  • Canon MF7170ii;
  • Canon MultiPASS L90;
  • Canon PC-D440;
  • Canon PC-D450;

Услуги системного администрирования могут понадобиться вам, если после перехода на Linux ваша компания не справляется с этим сама и вы нуждаетесь в консультациях и сопровождении опытного специалиста. При этом услуги сторонней компании обойдутся вам намного дешевле зарплаты штатного работника.

Автор:

Раскажи всем:

Комментарии (11)

Аватар Vadiok21.03.2011 в 07:49#1873
Спасибо, что пишите такие полезные статьи.
Не могли бы вы как-то дать знать, как устанавливать драйверы на Ubuntu 10.10 для струйных моделей. Хочу купить себе Canon MG5240 (МФУ аналог принтера iP4840), а на сайте тоже драйвера только для Ubuntu 10.04.
Аватар matkin30.03.2011 в 19:39#1903
Заставить принтер печатать, не так уж сложно, вот заставить сканировать это же устройство, если оно подключено - как сетевое, вот где бы найти ответ...
Аватар free_gad29.04.2011 в 14:38#2018
ПОМОГИТЕ!!!!!!!!
что теперь делать с 11.04 драйвер не работает!!!!!!!!!
Аватар kos03.05.2011 в 17:20#2042
Прошу помочь с установкой этого аппарата только в Убунте 11.04. Проделав все как описано выше уткнулся в сообщение центра приложений "Зависимость не может быть удовлетворена: gs-esp". Пробовал поставить драйвер версией выше и ниже картина такая же.
Аватар Vadiok03.05.2011 в 22:50#2053
Поздний ответ matkin'у:
В общем-то для моего МФУ Canon PIXMA MG5140 драйвера с сайта Canon'а работают и на 11.04 без всяких манипуляций. Сканер нормально появляется, например в GIMP:
Файл -> Создать -> ScanGear MP...
Только печать в Linux работает минимальная - выбора нет, только 600dpi, притом что принтер может печатать максимум 9600*2400dpi.
Аватар mora16.05.2011 в 10:55#2156
Кто прикрутил эту зверюгу к Ubuntu 11.04 отпешитесь или киньте ссылку на инфу...!!!
Заранее 64-х битное спасибо
Аватар anvar19.05.2011 в 13:37#2174
Я таки его прикрутил и без особых мучений. Сразу предупреждаю я лентяй. Потому прилепил до установки дров gdebi-установщик пакетов такой.

1. Качнем драйвера
UFRII/UFRII LT Printer Driver for Linux v2.20 (2.20), со страницы
http://software.canon-europe.com/products/0010471.asp
в архиве найдем два пакета
cndrvcups-common_2.20-1_i386.deb
cndrvcups-ufr2-uk_2.20-1_i386.deb

При попытке установить cndrvcups-common действительно неудовлетворяется зависимость gs-esp. Удовлетворим насильно, для этого качнем пакет http://packages.ubuntu.com/maverick/gs-esp (ссылка там внизу страницы)

2. порядок установки
-удалил старый принтер который в системе печати отображался (он остался с времен 10.10)
-установить gs-esp_8.71.dfsg.1-0ubuntu5.3_all.deb
-тут ребутнулся на всякий случай
-установить cndrvcups-common_2.20-1_i386.deb
-установить cndrvcups-ufr2-uk_2.20-1_i386.deb
-опять ребутнуть (для создания таинственного антуража)
-Заглянуть в администрирование печать и убедиться, что новый принтер Canon MF4010 Series таки есть.
-Проверить сам дрюкен процесс.
Аватар anvar19.05.2011 в 13:48#2175
На сайте http://software.canon-europe.com/products/0010471.asp есть ссылки на два драйвера
1. CQue 2.0.0 Linux Driver (v2.0.0) (для 32 и 64? пакеты и DEB и RPM)
2. UFRII/UFRII LT Printer Driver for Linux v2.20 (2.20)

По поводу первого CQue кто-то может что-либо сказать (общие впечатления)?
Я ставил второй потому, что с аналогичным работал в 10.10 и было всевнорме
Аватар Денис26.05.2011 в 14:16#2207
Доброго времени суток. Подскажите, как заставить печатать принтер Lexmark z 1420.
Аватар VladVons29.11.2015 в 23:52#6377
По этой инструкции завелся принтер и сканер Canon MF-4410.
http://linux-ubuntu.info/en/canon-mf-4410
Оставить комментарий


В рубрике "Железо":

Стартовали продажи Raspberry Pi 2

Стартовали продажи Raspberry Pi 2Raspberry Pi - миниатюрный одноплатный компьютер размером с кредитную карту за 35 долларов, чья новая версия представлена и поступила в продажу буквально на днях, теперь оснащен мощным 4-ядерным процессором ARM Cortex-A7 с тактовой частотой 900MHz и 1 Гб оперативной памяти. Как и его перва...

Установка драйвера Qualcomm Atheros QCA9565/ AR9565 для Ubuntu 12.04 (DELL Inspiron 3521)

Установка драйвера Qualcomm Atheros QCA9565/ AR9565 для Ubuntu 12.04 (DELL Inspiron 3521)Всем доброго времени суток! Недавно приобрел DELL Inspiron 3521. Ноут поставляется с предустановленной Ubuntu 12.04 LTS. При обновлении с 12.04 до 12.04.3 возникает ошибка во время установки пакета wifi драйвера oem-wireless-ath9k-3.9-rc4-2-dkms. После перезагрузки само собой перестаёт работать wifi...

Автоматическое включение NumLock при старте

Автоматическое включение NumLock при старте pingvinus.ru: Работая в среде Windows привыкаешь к тому, что NumLock всегда остается включенным или выключенным. В Ubuntu по-умолчанию NumLock всегда выключен и нужно его постоянно активировать, что не совсем удобно. Для тех, кто желает, чтобы NumLock был всегда включен, есть множество способов его автоматическог...

Установка сетевого драйвера ноутбуков Lenovo G480/G580 (Atheros AR8162 Fast Ethernet)

Установка сетевого драйвера ноутбуков Lenovo G480/G580 (Atheros AR8162  Fast Ethernet)Отличный ноубук для работы и учебы Lenovo G480 с 14-дюймовым дисплеем, и его более большой 15,6-дюймовый родственник Lenovo G580, могут похвастаться не только весьма привлекательным дизайном и выбором цвета корпуса, но еще и отличной ценой (модель поменьше в России обойдется вам примерно в 11 тысяч ...

Установка драйверов для Wi-Fi карт на чипах Ralink RT2870 в Ubuntu 12.04

Установка драйверов для Wi-Fi карт на чипах Ralink RT2870 в Ubuntu 12.04 electronics-repair.ru: Внимание! Данная инструкция действительна только для Ubuntu 12.04 с ядром 3.2.хх! В версиях ядра 3.5 и выше Вы получите крах системы! Драйвера rt2800, установленные в системе Ubuntu 12.04 не совсем корректно работают с Wi-Fi картами на базе чипов Ralink RT2870 (DLink DWA-160rev.B2 и ему подобные) - ...

Ubuntu 12.04.1/12.10 и принтер HP LazerJet P1102w

Ubuntu 12.04.1/12.10 и принтер HP LazerJet P1102w electronics-repair.ru: Проблема: принтер LazerJet P1102w не распознается Ubuntu; печать невозможна. Решение: Проблема с печатью связана с наличием флеш-диска в принтере, с которого устанавливаются драйвера в Windows, поэтому Ubuntu 12.04/12.10 распознает принтер именно как флеш-диск. Для изменения ситуации необходимо...

Восстановление рабочего стола после установки драйверов NVidia

Восстановление рабочего стола после установки драйверов NVidiaДля тех, у кого после установки NVIDIA драйверов пропадает рабочий стол... Жмем ctrl+alt+F1 и логинимся в текстовом режиме. Делаем: sudo apt-get install linux-source sudo apt-get install linux-headers-3.5.0-17-generic Удаляем существующие драйвера: sudo apt-get remove nvidia-current или sudo a...

Установка драйвера для AMD видеокарт в Ubuntu 12.10

Установка драйвера для AMD видеокарт в Ubuntu 12.10После выхода Ubuntu 12.10 многие "счастливые" владельцы видеокарт на чисетах AMD(ATI) столкнулись с проблемой установки проприетарного драйвера AMD Catalist 12.9. Подобные проблены возникают и у владельцев процессоров AMD Llano (A6-3650, A8-3850) если используется встроенная видеокарта. После устано...
Δ Наверх