Пожалуйста, укажите причину жалобы на комментарий пользователя и ваши контактные данные, по которым мы могли бы связаться с Вами для уточнения информации или уведомления о предпринятых действиях со стороны администрации сайта!
Отмена Отправить
X

E-mail:

Пароль:

| Забыли пароль?


Gimp 2.7 в Ubuntu и однооконный интерфейс в стиле Photoshop

Gimp 2.7 в Ubuntu и однооконный интерфейс в стиле Photoshop

Как уже давно известно, в следующем релизе Gimp нас ожидает долгожданный однооконный интерфейс в стиле Photoshop (все в одном окне), а также ввод текста прямо на изображении (а не в отдельном окне, как ранее). Конечно, на этом новинки не оканчиваются, но ради этих двух уже стоит попробовать тестовые версии Gimp 2.7 в деле.

тут также можно установить фотошоп на русском языке с ключом

Чтобы установить Gimp 2.7 в Ubuntu Linux достаточно выполнить несколько простых команд.

Для начала, удалим старую версию:

sudo apt-get autoremove gimp

И установим новую:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update
sudo apt-get install gimp

Для включения однооконного режима необходимо выбрать пункт меню "Окна - Однооконный режим" ("Windows - Single-window mode").

Автор:

Раскажи всем:

Комментарии (17)

Аватар Андрей25.01.2011 в 12:45#1735
О, классно, ато мне всегда не оч. нравилась менюшка из 3-ох окон:)
Аватар Андрей02.02.2011 в 02:37#1753
А как сделать, чтобы он при запуске был в оконном режиме, а не из нескольких панелей, ато в настройках не нашол
Аватар Алексей05.04.2011 в 19:29#1926
Спасибо, будем использовать.
Аватар Олег22.04.2011 в 11:15#1972
Класс! Большое спасибо!
Аватар dima13.05.2011 в 15:22#2139
Привет всем! Я просто добавил репозиторий и не удалял старую версию, все ок, работает тож хорошо! СПС за статью=)
Аватар Алексей22.05.2011 в 10:24#2188
Загружается, показывает стартовое окошко. Потом окошко исчезает - и все.
Запуск в терминале выдает

(gimp:10654): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
gimp: fatal error: Ошибка сегментирования
gimp (pid:10654): [E]xit, [H]alt, show [S]tack trace or [P]roceed:

Ну и что бы я не ввел на это предложение, программа закрывается
куда копать?
Аватар Brullworfel22.05.2011 в 11:49#2189
Может быть, какие то библиотеки от старого Gimp остались? Попробуйте применить все доступные обновления.
Аватар Алексей22.05.2011 в 12:47#2192
Удалил полностью все где встречается слово "gimp" через синаптик. Сделал установку снова. Да простят меня модераторы, но вот что пишет терминал при старте (в прошлый раз было то же самое):

~$ gimp
This is a development version of GIMP. Debug messages may appear here.


(gimp:14027): Gimp-Widgets-CRITICAL **: gimp_device_info_set_device: assertion `(info->device == NULL && GDK_IS_DEVICE (device)) || (GDK_IS_DEVICE (info->device) && device == NULL)' failed
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/file-openraster.py", line 16, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/python-eval.py", line 19, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/colorxhtml.py", line 24, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/palette-sort.py", line 16, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/py-slice.py", line 30, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/python-console.py", line 19, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/palette-offset.py", line 16, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/text-brush.py", line 20, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/foggify.py", line 19, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib/gimp/2.0/plug-ins/palette-to-gradient.py", line 16, in
from gimpfu import *
File "/usr/lib/gimp/2.0/python/gimpfu.py", line 76, in
import gimp
ImportError: /usr/lib/gimp/2.0/python/gimp.so: undefined symbol: PyGimpItem_Type

(gimp:14027): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
gimp: fatal error: Ошибка сегментирования
gimp (pid:14027): [E]xit, [H]alt, show [S]tack trace or [P]roceed: p

(script-fu:14044): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Аватар Сергей28.05.2011 в 14:50#2214
После всего этого, Gimp не запускается.
Переустановка (удаление, установка) не помогает.
И хрена теперь делать то???
Хочу Gimp.
Аватар Brullworfel29.05.2011 в 00:03#2217 ответ на #2214
sudo apt-get install ppa-purge
sudo ppa-purge ppa:matthaeus123/mrw-gimp-svn
Аватар Сергей30.05.2011 в 20:07#2224
Помогло!!!
Огромная благодарность!
Аватар Алексей02.06.2011 в 05:37#2241
Приведенный выше код не решает проблемы перехода на 2.7 версию. Он отменяет обновления, возвращая версию 2.6.
При обновлении снова на 2.7 разными путями (вручную, через менеджер обновлений) получил тот же набор ошибок, что и приводил ранее.
Главный вопрос - как перейти на 2.7 ???
Аватар Brullworfel02.06.2011 в 09:23#2243 ответ на #2241
Я вообще не понял о чем вы говорите. Чтобы перейти на версию 2.7 нужно добавить репозиторий PPA и обновить GIMP из него. Об этом подробно сказано в статье. А чтобы удалить 2.7 и вернуться к 2.6 нужно удалить PPA и удалить его пакеты утилитой ppa-purge, об этом читайте в моем комментарии выше.
Аватар Алексей02.06.2011 в 18:54#2245
Я говорю о том, что я выполнил все по приведенной инструкции, обновление прошло, но программа не запускается. В терминале выдает кучу ошибок, о которых я уже писал чуть ранее.
Аватар Александр20.06.2011 в 22:19#2337
Уважаемый Алексей, я тоже боролся с ошибкой, описанной Вами, а именно:
"
Загружается, показывает стартовое окошко. Потом окошко исчезает – и все.
Запуск в терминале выдает

(gimp:10654): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
gimp: fatal error: Ошибка сегментирования
gimp (pid:10654): [E]xit, [H]alt, show [S]tack trace or [P]roceed:
"
Оказалось, что проблема не в gimp вовсе, а в теме oxygen+gtk. Выключил её, поставил обычную qtcurve-и запустилось.
Нашел не я. Вычитал на форуме gimp.ru
Аватар Albert_Wesker29.03.2012 в 17:29#3176
Спасибо,всё заработало
Система Мутный Котэ(Lucid Lynx)
Аватар LinuxFanatRu26.04.2012 в 19:33#3298
sudo apt-get install gimp2.7
Вот так правильнее
Оставить комментарий


В рубрике "Программы":

Установка Mate 1.12.1 в Ubuntu 15.10 и 16.04

Установка Mate 1.12.1 в Ubuntu 15.10 и 16.04Mate - форк (ответвление) от Gnome 2, зародившееся в то недавнее время, когда разнообразные ОС и дистрибутивы начали гонку на объединение классического оконного интерфейса с интерфейсом для мобильных устройств. Именно после появления Unity, Gnome 3, Metro и других подобных интерфейсов, вме...

WPS Office: отличный аналог Microsoft Office для Linux

WPS Office: отличный аналог Microsoft Office для Linux Недавно один мой знакомый попросил установить на его компьютер Microsoft Office, вместо LibreOffice, который он назвал "каким-то китайским". Думаю, он имел ввиду отставший от современных тенденций интерфейс пользователя LibreOffice. Иронично, что через несколько дней я открыл для себя WPS Offi...

Twitch Indicator в Ubuntu!

Twitch Indicator в Ubuntu!Twitch indicator это индикатор - апплет для Ubuntu. Идея заключается в том, что бы уведомлять о любимых стримерах на рабочем столе, и, - если у вас установлена библиотека Livestreamer, запускать видео поток в VLC плеере. Twitch - ведущий сайт видеостриминговой платформы, где осно...

LibreOffice 5.0: что нового и как установить в Ubuntu

LibreOffice 5.0: что нового и как установить в Ubuntu The Document Foundation представила новую версию своего свободного офисного пакета LibreOffice 5.0 для Windows, Mac OS X и Linux. Несмотря на то, что поменялся первый номер версии ("мажорное обновление") и теперь он - аж 5.0, пользователи отмечают довольно малое количество нововведений. Самые крупн...

Whisker Menu 1.5.0 в Xubuntu

Whisker Menu 1.5.0  в Xubuntu webupd8.org: В Xubuntu, начиная с версии  14.04, вместо меню программ используется Whisker Меню. Недавно Whisker обновился до версии 1.5.0. Из основных наиболее заметных новшеств - возможность настройки прозрачности, изменение профиля и возможность создания фотографии в профиле пользователя, возможность пои...

LibreOffice 4.4 с обновленным интерфейсом

LibreOffice 4.4 с обновленным интерфейсомThe Document Foundation объявила о выпуске новой версии отличного бесплатного (и открытого!) офисного пакета LibreOffice 4.4. Из основных нововведений релиза отмечается улучшенный импорт файлов из других офисных пакетов (в том числе Microsoft Office последних версий) и многочисленные изменения во вн...

Новая версия векторного редактора Inkscape 0.91: новый движок и более 700 исправлений

Новая версия векторного редактора Inkscape 0.91: новый движок и более 700 исправленийПосле четырех с половиной лет разработки, Inkscape 0.91, наконец, выпущен. Это довольно серьезное обновление открытого бесплатного векторного графического редактора включает более 700 исправлений ошибок, новый движок отрисовки, много-потоковую обработку фильтров, новые инструменты. Новая версия Inks...

Официальное приложение Telegram в Ubuntu

Официальное приложение Telegram в UbuntuTelegram - просто отличная система обмена сообщениями! Внешне, Telegram практически полностью повторяет своего более популярного конкурента WhatsApp, за исключением 2 очень больших преимуществ: безопасность и кроссплатформенность. 1. Безопасность. В Telegram все сообщения шифруются очень сильны...
Δ Наверх